注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

拥有自己的梦想,跟随心的召唤

平凡是福

 
 
 

日志

 
 

JAVA类文件(.class文件)版本号与JDK的对应关系  

2011-11-14 09:18:19|  分类: Java |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
一个java的class文件是一个二进制文件,其中前四个字节是magic位,第五到第六个字节对应于minor和major,下面是这个类文件版本与JDK的对应关系:
 jdk minormajor 
 1.0 45 3
 1.1 45 3
 1.2 46 0
 1.3 47 0
 1.4 48 0
 1.5 49 0
 1.6 50 0

所以当见到类似如下的错误时就应该知道问题出在哪里了:
错误的类文件: ...\jetty-util-8.0.4.v20111024.jar(org/eclipse/jetty/util/TypeUtil.class) 
类文件具有错误的版本 50.0,应为 49.0
注:这个错误是提示你应该使用jdk1.6而不是jdk1.5。
  评论这张
 
阅读(1217)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017